January 4th, 2020

Hello computer!

зеленый провод

Компьютер у меня старенький, и уже местами глючный. Например, мне так и не удалось отключить в BIOS включение компа по клавиатуре или мыши - как ни ставь галочки, нажатие на клавишу включает комп. А ещё - материнская плата последнее время "не видит батарейку": при обесточивании компа выключателем "сзади" слетают настройки BIOS, после чего приходится их вбивать "с бумажки": мало того что слетает время, так ещё режим SATA слетает в эмуляцию IDE, и винда тупо не грузится. Батарейку проверял, менял - не помогает: что-то в железе сломалось. А поскольку у меня котик, и по клаве он топчется регулярно, то перед очередным отъездом на пару дней я решил поступить хитро.

Извлёк из жгута, идущего от БП к материнской плате, зелёный провод, разрезал его, и впаял выключатель. Кто не понял - БП всегда даёт на МП дежурное питание 5 вольт, а по зеленому проводу МП командует БП "включай всё!". Если провод перерезать - включить комп МП не удастся, но при этом дежурное питание никуда не денется, а значит BIOS не слетит.

Почувствовав себя ну очень умным сапёром, правильно выбравшим какой провод резать (зеленый!), разомкнул выключатель, постучал по клаве, удовлетворенно убедился что комп не реагирует, включил выключатель, и убедился что комп... не грузится. Лампочки зажглись, но экран чёрный и звуков нет. Потыкав во все кнопки включая ресет и выключатель (передний), всё-таки кратковременно обесточил комп, после чего комп включился, но настройки таки сбились. "Не сработало" - подумал я, выставил в BIOS режим SATA в AHCI, решив что "это важно, а остальное потом поправлю", и загрузил винду.

Винда же после этого:
1) заново нашла звуковую карту, и поставила её как новое устройство. Сбросив при этом вывод звука в какое-то очередное "никуда" (кажется в выход sp/dif на МП)
2) залогинилась на "коридорном сервере" не тем пользователем, которым логинилась несколько лет до этого (через net use в автозагрузке), а тупо текущим! И отказалась разлогиниваться или перелогиниваться! И при сбитии сеанса на сервере, почти мгновенно перелогинивалась "неправильным" пользователем! Помогла только блокировка "неправильного" пользователя на сервере, и многократное сбитие сеанса на сервере плюс перезагрузка клиента с зацикленным в батнике net use.

И если (1) я в принципе могу понять - плуг-энд-плей в винде штука такая, тут потрогал - везде всколыхнулось, а тут наверняка что-то в BIOS поменялось, то (2) меня несколько удивило. Несколько лет логинилась как надо, а именно сегодня, после того как я перерезал зеленый провод - сделать вот так вот? Но почему??